The Pomoto application requires technology which was removed from OS X 10.6 (Snow Leopard). Because of this, I have decided to disable the download link for Pomoto. This will have no effect on existing galleries or current users who continue to use the service with earlier versions of OS X. If you are a current user and considering an upgrade to Snow Leopard, please note that there will be no way, for the foreseeable future, to publish new albums and photos. I am considering a 'next generation' Pomoto which would of course run on Snow Leopard, but I can't make any promises and certainly can't give any timeline or roadmap. If you have any questions, please don't hesitate to contact us.